text.skipToContent text.skipToNavigation
false (View Projects)
This site uses cookies to improve your shopping experience. By closing this notice, you agree to our terms and conditions.
You are viewing products available in Nedco ontario division.Change
Choose your Nedco division
Update Cart?

Changing division would affect availability and pricing of products in your cart.

Your shipping address has been updated

Your Security is Important to Us

To provide the highest level of security, we will no longer support TLS V1.0 after June 30th, 2018. Learn more about TLS.


What does this mean for me?

Some browsers may not support TLS v1.1+ and you may need to change your settings or update your browser to continue to access this website after June 30th, 2018.


What are the supported browser versions?

The major browsers have all had updates within the last year to natively use TLS versions 1.1 and 1.2. Furthermore, in anticipation of the changes, the major browsers have added support for TLS 1.1 and 1.2 within the last two years. Here we will provide a list of the supported browsers including the minimum, recommended and best versions to use.


Minimum Recommended Best
Google Chrome Version 32 (released January 2014) or higher Version 40 (released January 2015) Version 47 (released December 2015)
For versions 32 through 40, you will need to manually enable support for TLS v1.1 and 1.2. To do this:

1. Open up Chrome
2. Use ALT-F on your keyboard and select “Settings”
3. Scroll down and click on “Show Advanced Settings”
4. Scroll down to the “Network” section and click on “Change proxy settings…”
5. Next, select the “Advanced” tab
6. Scroll down to the “Security” section
7. Locate and mark the “Use TLS 1.1 and TLS 1.2” checkbox
Google Android OS Browser Version 4.1 - Jelly Bean (released in 2012) or higher Version 5.0 - Lollipop (released in 2014) Version 6.0 - Marshmallow (released May 2015)
Firefox Version 24 (released September 2013) Version 38 (released May 2014) Version 43 (released December 2015)
If using version 24 of Firefox, you will need to manually enable it to use TLS v1.1 and 1.2. Instructions on how to do this
Internet Explorer Version 8 (released March 2009) -version 8 compatibility is only applicable to Windows 7 Version 11 (released June 2015) Edge (newest browser for Windows 10 users)
If using version 8 through 10 of Internet Explorer, you will need to manually enable it to use TLS v1.1 and 1.2. To do this:

1. Open Internet Explorer
2. Open internet options
3. Click Advanced Tab
4. Scroll down to the Security Section
5. Select Use TLS 1.1 and use TLS 1.2
Internet Explorer on Mobile Internet Explorer on Mobile Version 11 or higher
Safari on Mac Version 9 using OS X10.9 (released June 2013) Version 9 using OS X10.10 (released Oct 2014) Version 9 using OS X 10.11 (released June 2015)
Safari on Mobile Version 5 or higher
Edge Version 11 or higher
Opera Version 27 (released January 2015) Version 34 (released December 2015)
On versions prior to 34 you may need to manually enable TLS v1.1 and 1.2. To do this:

1. Open Opera settings with Alt P
2. Select Tab Advanced -> Security
3. For Auto-Updates select "Do not check for updates"
4. Confirm with OK
5. Open Opera settings
6. Select Tab Advanced -> Security
7. Select Security Protocols
8. Enable Security Protocols TLS 1.1 and TLS 1.2
9. Confirm with OK
Opera on Mobile 15.0.1162.60140 or higher

What is TLS?

TLS stands for Transport Layer Security, and it is the cryptographic protocol that is used when one connects to a server securely. In essence, when your browser connects to a store for secure transactions, it is using TLS encryption to ensure transactions are secure.


Why is support for TLS v1.0 being discontinued?

Due to its age, TLS v1.0 is no longer considered secure by industry standards and has gradually been discontinued across most services since mid 2015. And, as mentioned, support for TLS v1.0 is being discontinued globally in sometime in 2018. Instead, support for TLS versions 1.1 and 1.2 will be favored. In order to remain PCI compliant, we will update its server environment to accept only TLS v1.1 and TLS v1.2 just prior to the global cutoff.


Additional Resources

- Migrating from SSL and Early TLS

- Are You Ready for 30 June 2018? Saying Goodbye to SSL/early TLS

Nedco is one of the largest electrical wholesale suppliers providing a wide range of products for residential electricians and commercial contractors and large industrial organisations across Canada. We carry comprehensive product solutions for Lighting, Datacom, Wire & Cable, Power Management and Electrical Supplies. In addition to our online store, we have 69 branches throughout Canada where our customers can find what they need for their specific electrical projects as well as product knowledge and expertise from our staff.